Welcome to NuFi wallet's knowledge base. Learn more about NuFi (and access the wallet) on our homepage here or ask a question in our Discord server here.
Problem:
I already created a wallet but when I open NuFi, I don't see the option to log in; instead it asks me to create a new wallet or restore a wallet.
Cause:
NuFi can't find the wallet profile you created last time. This may be because:
a) you cleared the browser cache (either manually or automatically);
b) you were using incognito mode when you created a NuFi wallet in the past (which cleared the browser cache when the session ended); or
c) you used a privacy-focused browser that clears your data after each session.
In all of the above cases, the file that contains your NuFi wallet profile is deleted when the browser cache is cleared.
This file is saved in your browser cache when you set up your NuFi wallet, and if it is deleted at any point, NuFi can’t detect your existing wallet. This is why you are prompted to create a new wallet or restore an existing one. You will experience this issue if you use a different browser or browser profile from the one used when you set up your wallet; NuFi can't find the wallet file (which is in a different browser cache) and so you're unable to log in.
Solution:
Don't clear your browser cache after you've set up your NuFi wallet, and use the same browser and browser profile each time. Disable functions like ‘auto clear cache’ in your browser settings, and disable any browser extensions that may do this automatically when you close the browser.
If you prefer to use incognito mode, you will need to restore your wallet each time. The fastest way to do this is:
1) Restore your wallet again using the recovery phrase, or create a new wallet and re-pair your hardware wallet's accounts
2) Next, download/export a wallet backup file from wallet Settings
3) Use this backup file to restore your wallet on your next visit (click Restore > Upload file).
Restoring your wallet using a backup file will restore all accounts as well a customizations like names, display preferences, and so on.
Please note, you need to export the backup file again after making changes (such as adding a new account) as any changes to your wallet are not automatically saved in the backup file you downloaded to your computer.
If you need any help, you can open a support ticket here.