Welcome to NuFi wallet's knowledge base. Learn more about NuFi (and access the wallet) on our homepage here or ask a question in our Discord server here.

 

Problem:

When I open NuFi, I don't see the option to log in to my existing wallet; I have to restore my wallet using the recovery phrase or by re-pairing a hardware wallet.


Cause:

This happens when NuFi can't find the wallet profile you saved last time in the browser's cache. This may be because you:

a) cleared the browser cache (either manually or automatically);

b) used incognito mode when you created a NuFi wallet profile (which cleared the browser cache when the session was done); or

c) used a privacy-focused browser that clears all user data after each session.


If you clear your browser cache, you remove locally-stored site data (specifically the file saved to your computer which contains your NuFi wallet profile information), and NuFi can’t detect that you’ve already created a wallet. As a result, you’ll be prompted to create a new wallet or restore an existing one, and you won’t be able to access the login screen.


If you use incognito mode, site data isn’t saved after you close the browser (or browser tab), and the same problem as above occurs.


Solution:

To fix this, don't clear your browser cache, and disable functions like ‘auto clear cache’ in your browser settings as well as any browser add-ons that may do this automatically when you close the browser.


If you prefer to use incognito mode, you can:


1) Restore your wallet using the recovery phrase and re-pair any hardware wallets.

2) Download/export a backup file from Settings.

3) Use this backup file to restore your wallet instead of recovering your wallet using the recovery phrase (which is fine but takes much longer).


Restoring your wallet using a backup file will restore all previously-paired hardware wallets and mnemonic wallets at once. Please note, you need to export the backup file again after making any changes (such as adding a new mnemonic account, pairing a hardware wallet or renaming accounts) as the changes are not automatically saved in the file you previously downloaded.